0 votes
in Education by (1.7m points)
I am using Eclipse with Pydev and googleAppengine. I have python 2.7 installed. I am trying to run the easiest first program about hello world which is available here: http://code.google.com/appengine/docs/python/gettingstartedpython27/helloworld.html

The problem is my app.yaml is not recognizing Thread-safe and url keyword. It's giving the error message that it's not spelled correctly.

Please let me know what am I doing wrong.. Any help on this is highly appreciated.

My code: App.yaml:

application: helloworld

version: 1

runtime: python27

api_version: 1

threadsafe: true

handlers:

- url: /.*

  script: helloworld.app

and helloworld.py:

import webapp2

class MainPage(webapp2.RequestHandler):

  def get(self):

      self.response.headers['Content-Type'] = 'text/plain'

      self.response.out.write('Hello, webapp World!')

app = webapp2.WSGIApplication([('/', MainPage)],

                              debug=True)

JavaScript questions and answers, JavaScript questions pdf, JavaScript question bank, JavaScript questions and answers pdf, mcq on JavaScript pdf, JavaScript questions and solutions, JavaScript mcq Test , Interview JavaScript questions, JavaScript Questions for Interview, JavaScript MCQ (Multiple Choice Questions)

1 Answer

0 votes
by (1.7m points)
Python 2.7 isn't yet supported via the Google Plugin for Eclipse.
...